Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 13, 2025 - 20:15 CEST
Scheduled
We’re continuing our efforts to strengthen PreMiD’s stability and performance. As part of this, we will be performing maintenance that may result in some minor interruptions. Our goal is to keep any downtime as brief as possible while we work to increase the overall reliability of our service.
Thank you for your patience and understanding as we make PreMiD better for you!
— The Recodive Team
Posted Apr 13, 2025 - 20:04 CEST
This scheduled maintenance affected: API, Database, Website, Extension, and Discord bot.